package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$`)
var str = `ST078K
C022ZK
C1084A
H963F
K123AA
AB1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}