// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$").unwrap();
let string = "ST078K
C022ZK
C1084A
H963F
K123AA
AB1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}