re = /^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$/mi
str = 'ST078K
C022ZK
C1084A
H963F
K123AA
AB1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end