import re
regex = re.compile(r"^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ST078K\n"
"C022ZK\n"
"C1084A\n"
"H963F\n"
"K123AA\n"
"AB1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")