#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\u02BB\u02BC\u066C\u2018-\u201A\u275B\u275C]"
Local $sString = "ʻ - 02BB MODIFIER LETTER TURNED COMMA" & @CRLF & _
"ʼ - 02BC MODIFIER LETTER APOSTROPHE" & @CRLF & _
"٬ - 066C ARABIC THOUSANDS SEPARATOR" & @CRLF & _
"‘ - 2018 LEFT SINGLE QUOTATION MARK" & @CRLF & _
"’ - 2019 RIGHT SINGLE QUOTATION MARK" & @CRLF & _
"‚ - 201A SINGLE LOW-9 QUOTATION MARK" & @CRLF & _
"❛ - 275B HEAVY SINGLE TURNED COMMA QUOTATION MARK ORNAMENT" & @CRLF & _
"❜ - 275C HEAVY SINGLE COMMA QUOTATION MARK ORNAMENT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")