package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\u02BB\u02BC\u066C\u2018-\u201A\u275B\u275C]`)
var str = `ʻ - 02BB MODIFIER LETTER TURNED COMMA
ʼ - 02BC MODIFIER LETTER APOSTROPHE
٬ - 066C ARABIC THOUSANDS SEPARATOR
‘ - 2018 LEFT SINGLE QUOTATION MARK
’ - 2019 RIGHT SINGLE QUOTATION MARK
‚ - 201A SINGLE LOW-9 QUOTATION MARK
❛ - 275B HEAVY SINGLE TURNED COMMA QUOTATION MARK ORNAMENT
❜ - 275C HEAVY SINGLE COMMA QUOTATION MARK ORNAMENT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}