import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\u02BB\\u02BC\\u066C\\u2018-\\u201A\\u275B\\u275C]";
final String string = "ʻ - 02BB MODIFIER LETTER TURNED COMMA\n"
+ "ʼ - 02BC MODIFIER LETTER APOSTROPHE\n"
+ "٬ - 066C ARABIC THOUSANDS SEPARATOR\n"
+ "‘ - 2018 LEFT SINGLE QUOTATION MARK\n"
+ "’ - 2019 RIGHT SINGLE QUOTATION MARK\n"
+ "‚ - 201A SINGLE LOW-9 QUOTATION MARK\n"
+ "❛ - 275B HEAVY SINGLE TURNED COMMA QUOTATION MARK ORNAMENT\n"
+ "❜ - 275C HEAVY SINGLE COMMA QUOTATION MARK ORNAMENT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}