# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\u02BB\u02BC\u066C\u2018-\u201A\u275B\u275C]"
test_str = ("ʻ - 02BB MODIFIER LETTER TURNED COMMA\n"
"ʼ - 02BC MODIFIER LETTER APOSTROPHE\n"
"٬ - 066C ARABIC THOUSANDS SEPARATOR\n"
"‘ - 2018 LEFT SINGLE QUOTATION MARK\n"
"’ - 2019 RIGHT SINGLE QUOTATION MARK\n"
"‚ - 201A SINGLE LOW-9 QUOTATION MARK\n"
"❛ - 275B HEAVY SINGLE TURNED COMMA QUOTATION MARK ORNAMENT\n"
"❜ - 275C HEAVY SINGLE COMMA QUOTATION MARK ORNAMENT")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.