#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\t([^\t]*)\r?\n"
Local $sString = "Directory of D:\" & @CRLF & _
"D 0 19-Jan-15 16:12:16 FILE1" & @CRLF & _
"D 0 19-Jan-15 16:09:31 FILE2" & @CRLF & _
"D 0 21-Jan-15 14:10:33 FILE3" & @CRLF & _
"94951/218985 MB unused/total"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")