import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\t([^\\t]*)\\r?\\n";
final String string = "Directory of D:\\\n"
+ "D 0 19-Jan-15 16:12:16 FILE1\n"
+ "D 0 19-Jan-15 16:09:31 FILE2\n"
+ "D 0 21-Jan-15 14:10:33 FILE3\n"
+ "94951/218985 MB unused/total";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}