using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\t([^\t]*)\r?\n";
string input = @"Directory of D:\
D 0 19-Jan-15 16:12:16 FILE1
D 0 19-Jan-15 16:09:31 FILE2
D 0 21-Jan-15 14:10:33 FILE3
94951/218985 MB unused/total";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}