re = /\t([^\t]*)\r?\n/
str = 'Directory of D:\\
D 0 19-Jan-15 16:12:16 FILE1
D 0 19-Jan-15 16:09:31 FILE2
D 0 21-Jan-15 14:10:33 FILE3
94951/218985 MB unused/total'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end