#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\()([\/]*.*\/[^:]*):([0-9]+)"
Local $sString = "# CORRECT - MATCH FILE AND FILE NUMBER" & @CRLF & _
"at Object..test (resources/assets/js/tests/example.spec.js:4:23)" & @CRLF & _
"(resources/assets/js/tests/example.spec.js:4)" & @CRLF & _
"(/resources/assets/js/tests/example.php:449)" & @CRLF & _
"" & @CRLF & _
"# WRONG" & @CRLF & _
"/resources/assets/js/tests/example.php:449" & @CRLF & _
"resources/assets/js/tests/example.php:449" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")