import Foundation
let pattern = #"(?:\()([\/]*.*\/[^:]*):([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# CORRECT - MATCH FILE AND FILE NUMBER
at Object..test (resources/assets/js/tests/example.spec.js:4:23)
(resources/assets/js/tests/example.spec.js:4)
(/resources/assets/js/tests/example.php:449)
# WRONG
/resources/assets/js/tests/example.php:449
resources/assets/js/tests/example.php:449
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)