using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\()([\/]*.*\/[^:]*):([0-9]+)";
string input = @"# CORRECT - MATCH FILE AND FILE NUMBER
at Object..test (resources/assets/js/tests/example.spec.js:4:23)
(resources/assets/js/tests/example.spec.js:4)
(/resources/assets/js/tests/example.php:449)
# WRONG
/resources/assets/js/tests/example.php:449
resources/assets/js/tests/example.php:449
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}