$re = '/(?:\()([\/]*.*\/[^:]*):([0-9]+)/m';
$str = '# CORRECT - MATCH FILE AND FILE NUMBER
at Object..test (resources/assets/js/tests/example.spec.js:4:23)
(resources/assets/js/tests/example.spec.js:4)
(/resources/assets/js/tests/example.php:449)
# WRONG
/resources/assets/js/tests/example.php:449
resources/assets/js/tests/example.php:449
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);