$re = '/(<pre[^>]*?>((?:(?!pre>).|\n)*)<\/pre>)/i';
$str = '<pre></pre>
<pre>text</pre>
<pre>
text
<a></a>
</pre>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);