re = /(<pre[^>]*?>((?:(?!pre>).|\n)*)<\/pre>)/i
str = '<pre></pre>
<pre>text</pre>
<pre>
text
<a></a>
</pre>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end