#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=^(?:\+|00)?(?:[\-\/\(\)]?\d){11}$)(?:00|\+)[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])$"
Local $sString = "+48301234567" & @CRLF & _
"+4-8-3-0-1-2-3-4-5-6-7" & @CRLF & _
"+48/30/1234567" & @CRLF & _
"+48-30-12-345-67" & @CRLF & _
"+483011223344556677" & @CRLF & _
"0048301234567" & @CRLF & _
"+(48)30/1234567"
Local $sSubst = "+(\1\2) \3\4/\5\6-\7\8\9-\10\11"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)