const regex = /(?=^(?:\+|00)?(?:[\-\/\(\)]?\d){11}$)(?:00|\+)[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^(?:\\+|00)?(?:[\\-\\\/\\(\\)]?\\d){11}$)(?:00|\\+)[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])$', 'gm')
const str = `+48301234567
+4-8-3-0-1-2-3-4-5-6-7
+48/30/1234567
+48-30-12-345-67
+483011223344556677
0048301234567
+(48)30/1234567`;
const subst = `+(\1\2) \3\4/\5\6-\7\8\9-\10\11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);