$re = '/(?=^(?:\+|00)?(?:[\-\/\(\)]?\d){11}$)(?:00|\+)[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])$/m';
$str = '+48301234567
+4-8-3-0-1-2-3-4-5-6-7
+48/30/1234567
+48-30-12-345-67
+483011223344556677
0048301234567
+(48)30/1234567';
$subst = "+(\1\2) \3\4/\5\6-\7\8\9-\10\11";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;