import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\t ]*)(.*)$";
final String string = "<style type=\"text/css\">\n"
+ " html, body {\n"
+ " height:100%;\n"
+ " margin:0;\n"
+ " padding:0;\n"
+ " line-height:.8;\n"
+ " }\n\n"
+ " *, *:before, *:after {\n"
+ " -moz-box-sizing:border-box;\n"
+ " -webkit-box-sizing:border-box;\n"
+ " box-sizing:border-box;\n"
+ " }\n\n"
+ "</style>";
final String subst = "\\t$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}