// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\t ]*)(.*)$").unwrap();
let string = "<style type=\"text/css\">
html, body {
height:100%;
margin:0;
padding:0;
line-height:.8;
}
*, *:before, *:after {
-moz-box-sizing:border-box;
-webkit-box-sizing:border-box;
box-sizing:border-box;
}
</style>";
let substitution = "\\t$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}