import re
regex = re.compile(r"^([\t ]*)(.*)$", flags=re.MULTILINE)
test_str = ("<style type=\"text/css\">\n"
" html, body {\n"
" height:100%;\n"
" margin:0;\n"
" padding:0;\n"
" line-height:.8;\n"
" }\n\n"
" *, *:before, *:after {\n"
" -moz-box-sizing:border-box;\n"
" -webkit-box-sizing:border-box;\n"
" box-sizing:border-box;\n"
" }\n\n"
"</style>")
subst = "\\t$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)