using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\\(.*)\\(.*)\\(.*?)( \((\d{4})\))?\\(\d+)-(.*)\.flac$";
string input = @"c:\Users\Me\Music\FLAC\Rock\The Doors\Strange Days (1967)\07-People Are Strange.flac";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}