re = /.*\\(.*)\\(.*)\\(.*?)( \((\d{4})\))?\\(\d+)-(.*)\.flac$/i
str = 'c:\\Users\\Me\\Music\\FLAC\\Rock\\The Doors\\Strange Days (1967)\\07-People Are Strange.flac'
# Print the match result
str.match(re) do |match|
puts match.to_s
end