re = /[\w'-.]+\w|[\w'-]+\s*/
str = 'Hey y\'all, use T-Mobile & 23andme.com in the U.K.! Thanks.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end