using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?i:declare\s+?|(?!^)\G)(?:(?<var>@[\w@$#]+)\s+(?<type>\w+(?:\([^)]*\))?))\s*(?:,\s*|$)";
string input = @"declare @a int, @b numeric(1,2)
,@c varchar(20)
select @x foo, @y bar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}