const regex = /(?m)(?i:declare\s+?|(?!^)\G)(?:(?<var>@[\w@$#]+)\s+(?<type>\w+(?:\([^)]*\))?))\s*(?:,\s*|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?i:declare\\s+?|(?!^)\\G)(?:(?<var>@[\\w@$#]+)\\s+(?<type>\\w+(?:\\([^)]*\\))?))\\s*(?:,\\s*|$)', 'g')
const str = `declare @a int, @b numeric(1,2)
,@c varchar(20)
select @x foo, @y bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}