$re = '/(?m)(?i:declare\s+?|(?!^)\G)(?:(?<var>@[\w@$#]+)\s+(?<type>\w+(?:\([^)]*\))?))\s*(?:,\s*|$)/';
$str = 'declare @a int, @b numeric(1,2)
,@c varchar(20)
select @x foo, @y bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);