import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?i:declare\\s+?|(?!^)\\G)(?:(?<var>@[\\w@$#]+)\\s+(?<type>\\w+(?:\\([^)]*\\))?))\\s*(?:,\\s*|$)";
final String string = "declare @a int, @b numeric(1,2)\n"
+ " ,@c varchar(20)\n\n"
+ "select @x foo, @y bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}