import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,}\\..*";
final String string = "1. And this is line one\n"
+ "2. So this is line two\n"
+ "4. I think I missed something here...\n"
+ "5. Carrying on.\n"
+ "6. Feeling cozy again.\n"
+ "8. Wait, I missed something again.\n"
+ "10. I just missed more somethings again.\n"
+ "13. Dude, what's happening?\n"
+ "14. Things are alright again.\n"
+ "15. Still good.\n"
+ "17. Whoops, bubble.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}