re = /^\d{1,}\..*/mx
str = '1. And this is line one
2. So this is line two
4. I think I missed something here...
5. Carrying on.
6. Feeling cozy again.
8. Wait, I missed something again.
10. I just missed more somethings again.
13. Dude, what\'s happening?
14. Things are alright again.
15. Still good.
17. Whoops, bubble.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end