// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^\d{1,}\..*").unwrap();
let string = "1. And this is line one
2. So this is line two
4. I think I missed something here...
5. Carrying on.
6. Feeling cozy again.
8. Wait, I missed something again.
10. I just missed more somethings again.
13. Dude, what's happening?
14. Things are alright again.
15. Still good.
17. Whoops, bubble.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}