import re
regex = re.compile(r"""
^\d{1,}\..*
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("1. And this is line one\n"
"2. So this is line two\n"
"4. I think I missed something here...\n"
"5. Carrying on.\n"
"6. Feeling cozy again.\n"
"8. Wait, I missed something again.\n"
"10. I just missed more somethings again.\n"
"13. Dude, what's happening?\n"
"14. Things are alright again.\n"
"15. Still good.\n"
"17. Whoops, bubble.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")