const regex = /^\p{M}*\p{Lu}[\p{L}\p{M},.'-]+(?: [\p{L}\p{M},.'-]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\p{M}*\\p{Lu}[\\p{L}\\p{M},.\'-]+(?: [\\p{L}\\p{M},.\'-]+)*$', 'gm')
const str = `John Smith
Alberto del Muerto
INCORRECT
" John Smith "
" John Smith"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}