$re = '/^\p{M}*\p{Lu}[\p{L}\p{M},.\'-]+(?: [\p{L}\p{M},.\'-]+)*$/m';
$str = 'John Smith
Alberto del Muerto
INCORRECT
" John Smith "
" John Smith"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);