re = /^\p{M}*\p{Lu}[\p{L}\p{M},.'-]+(?: [\p{L}\p{M},.'-]+)*$/m
str = 'John Smith
Alberto del Muerto
INCORRECT
" John Smith "
" John Smith"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end