import re
regex = re.compile(r"^\p{M}*\p{Lu}[\p{L}\p{M},.'-]+(?: [\p{L}\p{M},.'-]+)*$", flags=re.MULTILINE)
test_str = ("John Smith\n"
"Alberto del Muerto\n\n"
"INCORRECT\n\n"
"\" John Smith \"\n"
"\" John Smith\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")