#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=(\s+))\1(?!$)"
Local $sString = "this is a test " & @CRLF & _
""
Local $sSubst = "essss"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)