use strict;
my $str = 'this is a test
';
my $regex = qr/(?=(\s+))\1(?!$)/p;
my $subst = 'essss';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";