using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\s+))\1(?!$)";
string substitution = @"essss";
string input = @"this is a test
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}