#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?m)(?<indent>\s*)describe\('([^']+)'[^{]+\{([\s\S]+?)\n\k<indent>\}\);"
Local $sString = "describe('a jasmine describe', function (){" & @CRLF & _
" it('login', function(){" & @CRLF & _
" //some function stuff" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" it('another it statement', function() {" & @CRLF & _
" //some additional stuff" & @CRLF & _
" });" & @CRLF & _
"});" & @CRLF & _
"" & @CRLF & _
" describe('a jasmine describe', function (){" & @CRLF & _
" it('login', function(){" & @CRLF & _
" //some function stuff" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" it('another it statement', function() {" & @CRLF & _
" //some additional stuff" & @CRLF & _
" });" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" describe('a jasmine describe', function (){" & @CRLF & _
" it('login', function(){" & @CRLF & _
" //some function stuff" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" it('another it statement', function() {" & @CRLF & _
" //some additional stuff" & @CRLF & _
" });" & @CRLF & _
" });"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")