re = /^(?m)(?<indent>\s*)describe\('([^']+)'[^{]+\{([\s\S]+?)\n\k<indent>\}\);/m
str = 'describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});
describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});
describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end