import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?m)(?<indent>\\s*)describe\\('([^']+)'[^\\{]+\\{([\\s\\S]+?)\\n\\k<indent>\\}\\);";
final String string = "describe('a jasmine describe', function (){\n"
+ " it('login', function(){\n"
+ " //some function stuff\n"
+ " });\n\n"
+ " it('another it statement', function() {\n"
+ " //some additional stuff\n"
+ " });\n"
+ "});\n\n"
+ " describe('a jasmine describe', function (){\n"
+ " it('login', function(){\n"
+ " //some function stuff\n"
+ " });\n\n"
+ " it('another it statement', function() {\n"
+ " //some additional stuff\n"
+ " });\n"
+ " });\n\n"
+ " describe('a jasmine describe', function (){\n"
+ " it('login', function(){\n"
+ " //some function stuff\n"
+ " });\n\n"
+ " it('another it statement', function() {\n"
+ " //some additional stuff\n"
+ " });\n"
+ " });";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}