#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(bad)\b"
Local $sString = "bad BAD bAd, bad" & @CRLF & _
"badassery " & @CRLF & _
"bangles" & @CRLF & _
"hubbad " & @CRLF & _
"B" & @CRLF & _
"A" & @CRLF & _
"D" & @CRLF & _
"" & @CRLF & _
"ba\nd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")