package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(bad)\b`)
var str = `bad BAD bAd, bad
badassery
bangles
hubbad
B
A
D
ba\nd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}