$re = '/\b(bad)\b/i';
$str = 'bad BAD bAd, bad
badassery
bangles
hubbad
B
A
D
ba\\nd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);