re = /\b(bad)\b/i
str = 'bad BAD bAd, bad
badassery
bangles
hubbad
B
A
D
ba\\nd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end