using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"01(?=\.jpg)(.*)(\d{2}).jpg";
string substitution = @"\2\1\2.jpg";
string input = @" <item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_55.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_56.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_57.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_58.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_59.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_60.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_61.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_62.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_63.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_64.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_65.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_66.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_67.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_68.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_69.jpg"" media-type=""image/jpeg""/>
<item id=""P2_0102_01.jpg"" href=""images/01_02/P2_0102_70.jpg"" media-type=""image/jpeg""/>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}